Out-of-bounds Write Affecting musl package, versions <0.9.15-1ubuntu0.1~esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.22% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-MUSL-291861
  • published27 Jun 2018
  • disclosed20 Feb 2020

Introduced: 27 Jun 2018

CVE-2014-3484  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 musl to version 0.9.15-1ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream musl package and not the musl package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

Multiple stack-based buffer overflows in the __dn_expand function in network/dn_expand.c in musl libc 1.1x before 1.1.2 and 0.9.13 through 1.0.3 allow remote attackers to (1) have unspecified impact via an invalid name length in a DNS response or (2) cause a denial of service (crash) via an invalid name length in a DNS response, related to an infinite loop with no output.

CVSS Base Scores

version 3.1