Out-of-Bounds Affecting musl package, versions <0.9.15-1ubuntu0.1~esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.21% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-MUSL-291866
  • published18 Aug 2017
  • disclosed18 Aug 2017

Introduced: 18 Aug 2017

CVE-2015-1817  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 musl to version 0.9.15-1ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream musl package and not the musl package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

Stack-based buffer overflow in the inet_pton function in network/inet_pton.c in musl libc 0.9.15 through 1.0.4, and 1.1.0 through 1.1.7 allows attackers to have unspecified impact via unknown vectors.