Code Affecting nbd package, versions <1:3.7-1ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.2% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-NBD-289489
  • published29 May 2015
  • disclosed29 May 2015

Introduced: 29 May 2015

CVE-2015-0847  (opens in a new tab)
CWE-17  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 nbd to version 1:3.7-1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nbd package and not the nbd package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

nbd-server.c in Network Block Device (nbd-server) before 3.11 does not properly handle signals, which allows remote attackers to cause a denial of service (deadlock) via unspecified vectors.

CVSS Base Scores

version 3.1