Integer Overflow or Wraparound Affecting nspr package, versions <2:4.12-0ubuntu0.14.04.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.13% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-NSPR-322080
  • published7 Aug 2016
  • disclosed7 Aug 2016

Introduced: 7 Aug 2016

CVE-2016-1951  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 nspr to version 2:4.12-0ubuntu0.14.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nspr package and not the nspr package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

Multiple integer overflows in io/prprf.c in Mozilla Netscape Portable Runtime (NSPR) before 4.12 allow remote attackers to cause a denial of service (buffer overflow) or possibly have unspecified other impact via a long string to a PR_*printf function.

CVSS Base Scores

version 3.1