NULL Pointer Dereference Affecting ntp package, versions <1:4.2.6.p5+dfsg-3ubuntu2.14.04.10


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
6.3% (94th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-NTP-372879
  • published30 Jan 2017
  • disclosed30 Jan 2017

Introduced: 30 Jan 2017

CVE-2015-7977  (opens in a new tab)
CWE-476  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 ntp to version 1:4.2.6.p5+dfsg-3ubuntu2.14.04.10 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ntp package and not the ntp package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

ntpd in NTP before 4.2.8p6 and 4.3.x before 4.3.90 allows remote attackers to cause a denial of service (NULL pointer dereference) via a ntpdc reslist command.

References

CVSS Base Scores

version 3.1