Improper Authentication Affecting paramiko package, versions <1.10.1-1git1ubuntu0.1


Severity

Recommended
high

Based on Ubuntu security rating.

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
27.11% (98th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-PARAMIKO-275393
  • published13 Mar 2018
  • disclosed13 Mar 2018

Introduced: 13 Mar 2018

CVE-2018-7750  (opens in a new tab)
CWE-287  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 paramiko to version 1.10.1-1git1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream paramiko package and not the paramiko package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

transport.py in the SSH server implementation of Paramiko before 1.17.6, 1.18.x before 1.18.5, 2.0.x before 2.0.8, 2.1.x before 2.1.5, 2.2.x before 2.2.3, 2.3.x before 2.3.2, and 2.4.x before 2.4.1 does not properly check whether authentication is completed before processing other requests, as demonstrated by channel-open. A customized SSH client can simply skip the authentication step.

CVSS Base Scores

version 3.1