Resource Exhaustion The advisory has been revoked - it doesn't affect any version of package phpmyadmin  (opens in a new tab)


Threat Intelligence

EPSS
3.57% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-PHPMYADMIN-1064795
  • published26 Jan 2021
  • disclosed13 Jan 2021

Introduced: 13 Jan 2021

CVE-2021-21252  (opens in a new tab)
CWE-400  (opens in a new tab)

Amendment

The Ubuntu security team deemed this advisory irrelevant for Ubuntu:14.04.

NVD Description

Note: Versions mentioned in the description apply only to the upstream phpmyadmin package and not the phpmyadmin package as distributed by Ubuntu.

The jQuery Validation Plugin provides drop-in validation for your existing forms. It is published as an npm package "jquery-validation". jquery-validation before version 1.19.3 contains one or more regular expressions that are vulnerable to ReDoS (Regular Expression Denial of Service). This is fixed in 1.19.3.