Integer Overflow or Wraparound Affecting pixman package, versions <0.30.2-2ubuntu1.2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.49% (71st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-PIXMAN-278317
  • published2 Dec 2018
  • disclosed31 Jul 2019

Introduced: 2 Dec 2018

CVE-2015-5297  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 pixman to version 0.30.2-2ubuntu1.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pixman package and not the pixman package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

An integer overflow issue has been reported in the general_composite_rect() function in pixman prior to version 0.32.8. An attacker could exploit this issue to cause an application using pixman to crash or, potentially, execute arbitrary code.