Numeric Errors Affecting pixman package, versions <0.30.2-2ubuntu1.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
5.62% (93rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-PIXMAN-278323
  • published13 Apr 2016
  • disclosed13 Apr 2016

Introduced: 13 Apr 2016

CVE-2014-9766  (opens in a new tab)
CWE-189  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 pixman to version 0.30.2-2ubuntu1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pixman package and not the pixman package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

Integer overflow in the create_bits function in pixman-bits-image.c in Pixman before 0.32.6 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via large height and stride values.

CVSS Base Scores

version 3.1