Integer Overflow or Wraparound Affecting pixman package, versions <0.30.2-2ubuntu1.2+esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.53% (75th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-PIXMAN-3100366
  • published4 Nov 2022
  • disclosed3 Nov 2022

Introduced: 3 Nov 2022

CVE-2022-44638  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 pixman to version 0.30.2-2ubuntu1.2+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pixman package and not the pixman package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

In libpixman in Pixman before 0.42.2, there is an out-of-bounds write (aka heap-based buffer overflow) in rasterize_edges_8 due to an integer overflow in pixman_sample_floor_y.

CVSS Base Scores

version 3.1