Out-of-Bounds Affecting procmail package, versions <3.22-21ubuntu0.2


Severity

Recommended
high

Based on Ubuntu security rating.

Threat Intelligence

EPSS
12.2% (97th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-PROCMAIL-288171
  • published16 Nov 2017
  • disclosed16 Nov 2017

Introduced: 16 Nov 2017

CVE-2017-16844  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 procmail to version 3.22-21ubuntu0.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream procmail package and not the procmail package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

Heap-based buffer overflow in the loadbuf function in formisc.c in formail in procmail 3.22 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted e-mail message because of a hardcoded realloc size, a different vulnerability than CVE-2014-3618.