Improper Privilege Management Affecting puppet package, versions <3.4.3-1ubuntu1.3


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.36% (30th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-PUPPET-364890
  • published9 Feb 2018
  • disclosed9 Feb 2018

Introduced: 9 Feb 2018

CVE-2017-10689  (opens in a new tab)
CWE-269  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 puppet to version 3.4.3-1ubuntu1.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream puppet package and not the puppet package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

In previous versions of Puppet Agent it was possible to install a module with world writable permissions. Puppet Agent 5.3.4 and 1.10.10 included a fix to this vulnerability.