Information Exposure Affecting putty package, versions <0.63-4ubuntu0.1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.59% (44th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-PUTTY-351053
  • published27 Mar 2015
  • disclosed27 Mar 2015

Introduced: 27 Mar 2015

CVE-2015-2157  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 putty to version 0.63-4ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream putty package and not the putty package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

The (1) ssh2_load_userkey and (2) ssh2_save_userkey functions in PuTTY 0.51 through 0.63 do not properly wipe SSH-2 private keys from memory, which allows local users to obtain sensitive information by reading the memory.

CVSS Base Scores

version 3.1