Out-of-Bounds Affecting putty package, versions *


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
32.81% (99th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-PUTTY-351096
  • published7 Apr 2016
  • disclosed7 Apr 2016

Introduced: 7 Apr 2016

CVE-2016-2563  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:14.04 putty.

NVD Description

Note: Versions mentioned in the description apply only to the upstream putty package and not the putty package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

Stack-based buffer overflow in the SCP command-line utility in PuTTY before 0.67 and KiTTY 0.66.6.3 and earlier allows remote servers to cause a denial of service (stack memory corruption) or execute arbitrary code via a crafted SCP-SINK file-size response to an SCP download request.