CVE-2021-27291 Affecting pygments package, versions <1.6+dfsg-1ubuntu1.1+esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.91% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-PYGMENTS-1086679
  • published18 Mar 2021
  • disclosed17 Mar 2021

Introduced: 17 Mar 2021

CVE-2021-27291  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 pygments to version 1.6+dfsg-1ubuntu1.1+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pygments package and not the pygments package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

In pygments 1.1+, fixed in 2.7.4, the lexers used to parse programming languages rely heavily on regular expressions. Some of the regular expressions have exponential or cubic worst-case complexity and are vulnerable to ReDoS. By crafting malicious input, an attacker can cause a denial of service.

CVSS Base Scores

version 3.1