Out-of-Bounds Affecting python3.4 package, versions <3.4.0-2ubuntu1.1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
7.85% (95th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-PYTHON34-306401
  • published24 Aug 2017
  • disclosed24 Aug 2017

Introduced: 24 Aug 2017

CVE-2014-4616  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 python3.4 to version 3.4.0-2ubuntu1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python3.4 package and not the python3.4 package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

Array index error in the scanstring function in the _json module in Python 2.7 through 3.5 and simplejson before 2.6.1 allows context-dependent attackers to read arbitrary process memory via a negative index value in the idx argument to the raw_decode function.

CVSS Base Scores

version 3.1