Improper Input Validation Affecting python3.4 package, versions <3.4.3-1ubuntu1~14.04.7+esm7


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.96% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-PYTHON34-589946
  • published14 Jul 2020
  • disclosed13 Jul 2020

Introduced: 13 Jul 2020

CVE-2019-20907  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 python3.4 to version 3.4.3-1ubuntu1~14.04.7+esm7 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python3.4 package and not the python3.4 package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

In Lib/tarfile.py in Python through 3.8.3, an attacker is able to craft a TAR archive leading to an infinite loop when opened by tarfile.open, because _proc_pax lacks header validation.

References

CVSS Base Scores

version 3.1