SQL Injection Affecting quassel package, versions <0.10.0-0ubuntu2.2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.99% (80th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-QUASSEL-383422
  • published14 May 2015
  • disclosed14 May 2015

Introduced: 14 May 2015

CVE-2015-3427  (opens in a new tab)
CWE-89  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 quassel to version 0.10.0-0ubuntu2.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream quassel package and not the quassel package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

Quassel before 0.12.2 does not properly re-initialize the database session when the PostgreSQL database is restarted, which allows remote attackers to conduct SQL injection attacks via a \ (backslash) in a message. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-4422.

CVSS Base Scores

version 3.1