NULL Pointer Dereference Affecting quassel package, versions <0.10.0-0ubuntu2.3


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.28% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-QUASSEL-383430
  • published8 May 2018
  • disclosed8 May 2018

Introduced: 8 May 2018

CVE-2018-1000179  (opens in a new tab)
CWE-476  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 quassel to version 0.10.0-0ubuntu2.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream quassel package and not the quassel package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

A NULL Pointer Dereference of CWE-476 exists in quassel version 0.12.4 in the quasselcore void CoreAuthHandler::handle(const Login &msg) coreauthhandler.cpp line 235 that allows an attacker to cause a denial of service.