SQL Injection Affecting rails-4.0 package, versions *


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.27% (67th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-RAILS40-310773
  • published20 Feb 2014
  • disclosed20 Feb 2014

Introduced: 20 Feb 2014

CVE-2014-0080  (opens in a new tab)
CWE-89  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:14.04 rails-4.0.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rails-4.0 package and not the rails-4.0 package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

SQL injection vulnerability in activerecord/lib/active_record/connection_adapters/postgresql/cast.rb in Active Record in Ruby on Rails 4.0.x before 4.0.3, and 4.1.0.beta1, when PostgreSQL is used, allows remote attackers to execute "add data" SQL commands via vectors involving \ (backslash) characters that are not properly handled in operations on array columns.

CVSS Base Scores

version 3.1