Channel and Path Errors Affecting rkhunter package, versions <1.4.0-3ubuntu0.1~esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.37% (84th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-RKHUNTER-313582
  • published21 Jul 2017
  • disclosed21 Jul 2017

Introduced: 21 Jul 2017

CVE-2017-7480  (opens in a new tab)
CWE-417  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 rkhunter to version 1.4.0-3ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rkhunter package and not the rkhunter package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

rkhunter versions before 1.4.4 are vulnerable to file download over insecure channel when doing mirror update resulting into potential remote code execution.

CVSS Base Scores

version 3.1