Resource Exhaustion Affecting ruby2.0 package, versions <2.0.0.484-1ubuntu2.10


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
4.46% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-RUBY20-281608
  • published3 Apr 2018
  • disclosed3 Apr 2018

Introduced: 3 Apr 2018

CVE-2018-8777  (opens in a new tab)
CWE-400  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 ruby2.0 to version 2.0.0.484-1ubuntu2.10 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby2.0 package and not the ruby2.0 package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

In Ruby before 2.2.10, 2.3.x before 2.3.7, 2.4.x before 2.4.4, 2.5.x before 2.5.1, and 2.6.0-preview1, an attacker can pass a large HTTP request with a crafted header to WEBrick server or a crafted body to WEBrick server/handler and cause a denial of service (memory consumption).