OS Command Injection Affecting rxvt-unicode package, versions *


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
4.1% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-RXVTUNICODE-311854
  • published14 May 2014
  • disclosed14 May 2014

Introduced: 14 May 2014

CVE-2014-3121  (opens in a new tab)
CWE-78  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:14.04 rxvt-unicode.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rxvt-unicode package and not the rxvt-unicode package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

rxvt-unicode before 9.20 does not properly handle OSC escape sequences, which allows user-assisted remote attackers to manipulate arbitrary X window properties and execute arbitrary commands.

CVSS Base Scores

version 3.1