Improper Input Validation Affecting shibboleth-sp2 package, versions *


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.94% (78th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-SHIBBOLETHSP2-317679
  • published31 Mar 2015
  • disclosed31 Mar 2015

Introduced: 31 Mar 2015

CVE-2015-2684  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:14.04 shibboleth-sp2.

NVD Description

Note: Versions mentioned in the description apply only to the upstream shibboleth-sp2 package and not the shibboleth-sp2 package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

Shibboleth Service Provider (SP) before 2.5.4 allows remote authenticated users to cause a denial of service (crash) via a crafted SAML message.

CVSS Base Scores

version 3.1