Improper Input Validation Affecting simplestreams package, versions <0.1.0~bzr341-0ubuntu2.2


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.71% (75th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-SIMPLESTREAMS-262578
  • published9 Oct 2015
  • disclosed9 Oct 2015

Introduced: 9 Oct 2015

CVE-2015-1337  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 simplestreams to version 0.1.0~bzr341-0ubuntu2.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream simplestreams package and not the simplestreams package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

Simple Streams (simplestreams) does not properly verify the GPG signatures of disk image files, which allows remote mirror servers to spoof disk images and have unspecified other impact via a 403 (aka Forbidden) response.

CVSS Base Scores

version 3.1