SQL Injection Affecting slurm-llnl package, versions <2.6.5-1ubuntu0.1~esm4


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.88% (80th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-SLURMLLNL-449559
  • published15 Mar 2018
  • disclosed15 Mar 2018

Introduced: 15 Mar 2018

CVE-2018-7033  (opens in a new tab)
CWE-89  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 slurm-llnl to version 2.6.5-1ubuntu0.1~esm4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream slurm-llnl package and not the slurm-llnl package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

SchedMD Slurm before 17.02.10 and 17.11.x before 17.11.5 allows SQL Injection attacks against SlurmDBD.