OS Command Injection Affecting spamassassin package, versions <3.4.2-0ubuntu0.14.04.1+esm3


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
6.13% (93rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-SPAMASSASSIN-1244923
  • published30 Mar 2021
  • disclosed25 Mar 2021

Introduced: 25 Mar 2021

CVE-2020-1946  (opens in a new tab)
CWE-78  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 spamassassin to version 3.4.2-0ubuntu0.14.04.1+esm3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream spamassassin package and not the spamassassin package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

In Apache SpamAssassin before 3.4.5, malicious rule configuration (.cf) files can be configured to run system commands without any output or errors. With this, exploits can be injected in a number of scenarios. In addition to upgrading to SA version 3.4.5, users should only use update channels or 3rd party .cf files from trusted places.

CVSS Base Scores

version 3.1