Improper Input Validation Affecting subversion package, versions <1.8.8-1ubuntu3.3


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
18.89% (98th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-SUBVERSION-344391
  • published11 Aug 2017
  • disclosed11 Aug 2017

Introduced: 11 Aug 2017

CVE-2017-9800  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 subversion to version 1.8.8-1ubuntu3.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream subversion package and not the subversion package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

A maliciously constructed svn+ssh:// URL would cause Subversion clients before 1.8.19, 1.9.x before 1.9.7, and 1.10.0.x through 1.10.0-alpha3 to run an arbitrary shell command. Such a URL could be generated by a malicious server, by a malicious user committing to a honest server (to attack another user of that server's repositories), or by a proxy server. The vulnerability affects all clients, including those that use file://, http://, and plain (untunneled) svn://.