Out-of-bounds Read Affecting tcpflow package, versions <1.4.4+repack1-2ubuntu0.1~esm1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.3% (70th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-TCPFLOW-345261
  • published17 Oct 2018
  • disclosed17 Oct 2018

Introduced: 17 Oct 2018

CVE-2018-18409  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 tcpflow to version 1.4.4+repack1-2ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tcpflow package and not the tcpflow package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

A stack-based buffer over-read exists in setbit() at iptree.h of TCPFLOW 1.5.0, due to received incorrect values causing incorrect computation, leading to denial of service during an address_histogram call or a get_histogram call.