Improper Input Validation Affecting teeworlds package, versions <0.6.2+dfsg-2~build0.14.04.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.73% (85th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-TEEWORLDS-310049
  • published9 Dec 2014
  • disclosed9 Dec 2014

Introduced: 9 Dec 2014

CVE-2014-9351  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 teeworlds to version 0.6.2+dfsg-2~build0.14.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream teeworlds package and not the teeworlds package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

engine/server/server.cpp in Teeworlds 0.6.x before 0.6.3 allows remote attackers to read memory and cause a denial of service (crash) via unspecified vectors.

CVSS Base Scores

version 3.1