Improper Input Validation Affecting texlive-base package, versions <2013.20140215-1ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
7.15% (94th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-TEXLIVEBASE-296590
  • published2 May 2017
  • disclosed2 May 2017

Introduced: 2 May 2017

CVE-2016-10243  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 texlive-base to version 2013.20140215-1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream texlive-base package and not the texlive-base package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

TeX Live allows remote attackers to execute arbitrary commands by leveraging inclusion of mpost in shell_escape_commands in the texmf.cnf config file.