Out-of-Bounds Affecting tidy package, versions <20091223cvs-1.2ubuntu1.1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.84% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-TIDY-297961
  • published11 Aug 2015
  • disclosed11 Aug 2015

Introduced: 11 Aug 2015

CVE-2015-5523  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 tidy to version 20091223cvs-1.2ubuntu1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tidy package and not the tidy package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

The ParseValue function in lexer.c in tidy before 4.9.31 allows remote attackers to cause a denial of service (crash) via vectors involving multiple whitespace characters before an empty href, which triggers a large memory allocation.

CVSS Base Scores

version 3.1