Improper Authentication Affecting unattended-upgrades package, versions <0.82.1ubuntu2.3


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.44% (70th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-UNATTENDEDUPGRADES-293877
  • published1 Jul 2015
  • disclosed1 Jul 2015

Introduced: 1 Jul 2015

CVE-2015-1330  (opens in a new tab)
CWE-287  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 unattended-upgrades to version 0.82.1ubuntu2.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream unattended-upgrades package and not the unattended-upgrades package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

unattended-upgrades before 0.86.1 does not properly authenticate packages when the (1) force-confold or (2) force-confnew dpkg options are enabled in the DPkg::Options::* apt configuration, which allows remote man-in-the-middle attackers to upload and execute arbitrary packages via unspecified vectors.

CVSS Base Scores

version 3.1