Race Condition Affecting unity package, versions <7.2.2+14.04.20140714-0ubuntu1.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.3% (22nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-UNITY-278623
  • published7 Aug 2014
  • disclosed7 Aug 2014

Introduced: 7 Aug 2014

CVE-2014-5195  (opens in a new tab)
CWE-362  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 unity to version 7.2.2+14.04.20140714-0ubuntu1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream unity package and not the unity package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

Unity before 7.2.3 and 7.3.x before 7.3.1, as used in Ubuntu, does not properly take focus of the keyboard when switching to the lock screen, which allows physically proximate attackers to bypass the lock screen by (1) leveraging a machine that had text selected when locking or (2) resuming from a suspension.

CVSS Base Scores

version 3.1