Out-of-Bounds Affecting xdelta3 package, versions <3.0.7-dfsg-2ubuntu0.2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
4.16% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-XDELTA3-307437
  • published19 Apr 2016
  • disclosed19 Apr 2016

Introduced: 19 Apr 2016

CVE-2014-9765  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 xdelta3 to version 3.0.7-dfsg-2ubuntu0.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream xdelta3 package and not the xdelta3 package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

Buffer overflow in the main_get_appheader function in xdelta3-main.h in xdelta3 before 3.0.9 allows remote attackers to execute arbitrary code via a crafted input file.

CVSS Base Scores

version 3.1