Access Restriction Bypass Affecting xscreensaver package, versions <5.15-3+deb7u1ubuntu0.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.51% (40th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-XSCREENSAVER-384588
  • published10 Nov 2015
  • disclosed10 Nov 2015

Introduced: 10 Nov 2015

CVE-2015-8025  (opens in a new tab)
CWE-264  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 xscreensaver to version 5.15-3+deb7u1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream xscreensaver package and not the xscreensaver package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

driver/subprocs.c in XScreenSaver before 5.34 does not properly perform an internal consistency check, which allows physically proximate attackers to bypass the lock screen by hot swapping monitors.

CVSS Base Scores

version 3.1