Out-of-bounds Write Affecting zsh package, versions <5.0.2-3ubuntu6.2


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.43% (36th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-ZSH-351926
  • published9 Mar 2018
  • disclosed9 Mar 2018

Introduced: 9 Mar 2018

CVE-2018-1071  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 zsh to version 5.0.2-3ubuntu6.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream zsh package and not the zsh package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

zsh through version 5.4.2 is vulnerable to a stack-based buffer overflow in the exec.c:hashcmd() function. A local attacker could exploit this to cause a denial of service.

CVSS Base Scores

version 3.1