Improper Input Validation Affecting zsh package, versions <5.0.2-3ubuntu6.3


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.72% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-ZSH-351933
  • published25 Sept 2018
  • disclosed5 Sept 2018

Introduced: 5 Sep 2018

CVE-2018-13259  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 zsh to version 5.0.2-3ubuntu6.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream zsh package and not the zsh package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

An issue was discovered in zsh before 5.6. Shebang lines exceeding 64 characters were truncated, potentially leading to an execve call to a program name that is a substring of the intended one.