Use of Externally-Controlled Format String Affecting graphviz package, versions <2.38.0-5ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
5.57% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1410-GRAPHVIZ-294432
  • published3 Dec 2014
  • disclosed3 Dec 2014

Introduced: 3 Dec 2014

CVE-2014-9157  (opens in a new tab)
CWE-134  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.10 graphviz to version 2.38.0-5ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream graphviz package and not the graphviz package as distributed by Ubuntu. See How to fix? for Ubuntu:14.10 relevant fixed versions and status.

Format string vulnerability in the yyerror function in lib/cgraph/scan.l in Graphviz allows remote attackers to have unspecified impact via format string specifiers in unknown vectors, which are not properly handled in an error string.

CVSS Base Scores

version 3.1