Out-of-bounds Read Affecting konversation package, versions <1.5-1ubuntu1.14.10.1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.55% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1410-KONVERSATION-307791
  • published6 Nov 2014
  • disclosed6 Nov 2014

Introduced: 6 Nov 2014

CVE-2014-8483  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.10 konversation to version 1.5-1ubuntu1.14.10.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream konversation package and not the konversation package as distributed by Ubuntu. See How to fix? for Ubuntu:14.10 relevant fixed versions and status.

The blowfishECB function in core/cipher.cpp in Quassel IRC 0.10.0 allows remote attackers to cause a denial of service (out-of-bounds read) via a malformed string.

CVSS Base Scores

version 3.1