Numeric Errors Affecting libxfont package, versions <1:1.4.99.901-1ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
4.95% (93rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1410-LIBXFONT-313089
  • published20 Mar 2015
  • disclosed20 Mar 2015

Introduced: 20 Mar 2015

CVE-2015-1804  (opens in a new tab)
CWE-189  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.10 libxfont to version 1:1.4.99.901-1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libxfont package and not the libxfont package as distributed by Ubuntu. See How to fix? for Ubuntu:14.10 relevant fixed versions and status.

The bdfReadCharacters function in bitmap/bdfread.c in X.Org libXfont before 1.4.9 and 1.5.x before 1.5.1 does not properly perform type conversion for metrics values, which allows remote authenticated users to cause a denial of service (out-of-bounds memory access) and possibly execute arbitrary code via a crafted BDF font file.

CVSS Base Scores

version 3.1