Access Restriction Bypass Affecting mountall package, versions <2.54ubuntu0.14.10.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.51% (40th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1410-MOUNTALL-267001
  • published25 Nov 2014
  • disclosed25 Nov 2014

Introduced: 25 Nov 2014

CVE-2014-1421  (opens in a new tab)
CWE-264  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.10 mountall to version 2.54ubuntu0.14.10.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mountall package and not the mountall package as distributed by Ubuntu. See How to fix? for Ubuntu:14.10 relevant fixed versions and status.

mountall 1.54, as used in Ubuntu 14.10, does not properly handle the umask when using the mount utility, which allows local users to bypass intended access restrictions via unspecified vectors.

CVSS Base Scores

version 3.1