CVE-2013-1753 Affecting python2.7 package, versions <2.7.8-10ubuntu1.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.46% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1410-PYTHON27-306479
  • published27 Jun 2018
  • disclosed11 Mar 2020

Introduced: 27 Jun 2018

CVE-2013-1753  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.10 python2.7 to version 2.7.8-10ubuntu1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python2.7 package and not the python2.7 package as distributed by Ubuntu. See How to fix? for Ubuntu:14.10 relevant fixed versions and status.

The gzip_decode function in the xmlrpc client library in Python 3.4 and earlier allows remote attackers to cause a denial of service (memory consumption) via a crafted HTTP request.

CVSS Base Scores

version 3.1