Link Following Affecting apport package, versions <2.17.2-0ubuntu1.5


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.91% (56th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1504-APPORT-369348
  • published1 Oct 2015
  • disclosed1 Oct 2015

Introduced: 1 Oct 2015

CVE-2015-1338  (opens in a new tab)
CWE-59  (opens in a new tab)

How to fix?

Upgrade Ubuntu:15.04 apport to version 2.17.2-0ubuntu1.5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream apport package and not the apport package as distributed by Ubuntu. See How to fix? for Ubuntu:15.04 relevant fixed versions and status.

kernel_crashdump in Apport before 2.19 allows local users to cause a denial of service (disk consumption) or possibly gain privileges via a (1) symlink or (2) hard link attack on /var/crash/vmcore.log.

CVSS Base Scores

version 3.1