Information Exposure Affecting cinder package, versions <1:2015.1.0-0ubuntu1.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.62% (85th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1504-CINDER-307846
  • published25 Jun 2015
  • disclosed25 Jun 2015

Introduced: 25 Jun 2015

CVE-2015-1851  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade Ubuntu:15.04 cinder to version 1:2015.1.0-0ubuntu1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cinder package and not the cinder package as distributed by Ubuntu. See How to fix? for Ubuntu:15.04 relevant fixed versions and status.

OpenStack Cinder before 2014.1.5 (icehouse), 2014.2.x before 2014.2.4 (juno), and 2015.1.x before 2015.1.1 (kilo) allows remote authenticated users to read arbitrary files via a crafted qcow2 signature in an image to the upload-to-image command.

CVSS Base Scores

version 3.1