Information Exposure Affecting django-markupfield package, versions <1.2.1-2+deb8u1build0.15.04.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.79% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1504-DJANGOMARKUPFIELD-288939
  • published24 Apr 2015
  • disclosed24 Apr 2015

Introduced: 24 Apr 2015

CVE-2015-0846  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade Ubuntu:15.04 django-markupfield to version 1.2.1-2+deb8u1build0.15.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream django-markupfield package and not the django-markupfield package as distributed by Ubuntu. See How to fix? for Ubuntu:15.04 relevant fixed versions and status.

django-markupfield before 1.3.2 uses the default docutils RESTRUCTUREDTEXT_FILTER_SETTINGS settings, which allows remote attackers to include and read arbitrary files via unspecified vectors.

CVSS Base Scores

version 3.1