Out-of-Bounds Affecting miniupnpc package, versions <1.9.20140610-2ubuntu1.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
4.78% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1504-MINIUPNPC-296864
  • published2 Nov 2015
  • disclosed2 Nov 2015

Introduced: 2 Nov 2015

CVE-2015-6031  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:15.04 miniupnpc to version 1.9.20140610-2ubuntu1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream miniupnpc package and not the miniupnpc package as distributed by Ubuntu. See How to fix? for Ubuntu:15.04 relevant fixed versions and status.

Buffer overflow in the IGDstartelt function in igd_desc_parse.c in the MiniUPnP client (aka MiniUPnPc) before 1.9.20150917 allows remote UPNP servers to cause a denial of service (application crash) and possibly execute arbitrary code via an "oversized" XML element name.

CVSS Base Scores

version 3.1