Directory Traversal Affecting network-manager package, versions <0.9.10.0-4ubuntu15.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.53% (41st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1504-NETWORKMANAGER-300564
  • published29 Apr 2015
  • disclosed29 Apr 2015

Introduced: 29 Apr 2015

CVE-2015-1322  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade Ubuntu:15.04 network-manager to version 0.9.10.0-4ubuntu15.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream network-manager package and not the network-manager package as distributed by Ubuntu. See How to fix? for Ubuntu:15.04 relevant fixed versions and status.

Directory traversal vulnerability in the Ubuntu network-manager package for Ubuntu (vivid) before 0.9.10.0-4ubuntu15.1, Ubuntu 14.10 before 0.9.8.8-0ubuntu28.1, and Ubuntu 14.04 LTS before 0.9.8.8-0ubuntu7.1 allows local users to change the modem device configuration or read arbitrary files via a .. (dot dot) in the file name in a request to read modem device contexts (com.canonical.NMOfono.ReadImsiContexts).

CVSS Base Scores

version 3.1