Improper Input Validation Affecting perl package, versions <5.20.2-2ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.12% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1504-PERL-327661
  • published13 Jan 2016
  • disclosed13 Jan 2016

Introduced: 13 Jan 2016

CVE-2015-8607  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:15.04 perl to version 5.20.2-2ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream perl package and not the perl package as distributed by Ubuntu. See How to fix? for Ubuntu:15.04 relevant fixed versions and status.

The canonpath function in the File::Spec module in PathTools before 3.62, as used in Perl, does not properly preserve the taint attribute of data, which might allow context-dependent attackers to bypass the taint protection mechanism via a crafted string.

CVSS Base Scores

version 3.1