Improper Data Handling Affecting ruby-rack package, versions <1.5.2-3+deb8u1build0.15.04.1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
7.99% (95th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1504-RUBYRACK-322192
  • published26 Jul 2015
  • disclosed26 Jul 2015

Introduced: 26 Jul 2015

CVE-2015-3225  (opens in a new tab)
CWE-19  (opens in a new tab)

How to fix?

Upgrade Ubuntu:15.04 ruby-rack to version 1.5.2-3+deb8u1build0.15.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby-rack package and not the ruby-rack package as distributed by Ubuntu. See How to fix? for Ubuntu:15.04 relevant fixed versions and status.

lib/rack/utils.rb in Rack before 1.5.4 and 1.6.x before 1.6.2, as used with Ruby on Rails 3.x and 4.x and other products, allows remote attackers to cause a denial of service (SystemStackError) via a request with a large parameter depth.

CVSS Base Scores

version 3.1